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Introduction 

Thank you for buying a Panasonic product. Before you use the product, please carefully read 
the installation instructions and the users manual, and understand their contents in detail to 
use the product properly. 

Types of Manual 

• There are different types of users manual for the FP7 series, as listed below. Please refer to 
a relevant manual for the unit and purpose of your use. 

• The manuals can be downloaded on our website: 
http://industrial.panasonic.com/ac/e/dl_center/manual/ . 

Unit name or purpose of 
use 

Manual name Manual code 

FP7 Power Supply Unit FP7 CPU Unit Users Manual 
 (Hardware) WUME-FP7CPUH 

FP7 CPU Unit 

 

Instructions for Built-in 
COM Port 
FP7 Extension 
(Communication) 
Cassette 

FP7 CPU Unit Users Manual 
 (COM Port Communication) WUME- FP7COM 

 Instructions for Built-in 
LAN Port 

FP7 CPU Unit Users Manual 
 (LAN Port Communication) WUME-FP7LAN 

FP7 Digital Input/Output Unit FP7 Digital Input/Output Unit Users Manual WUME-FP7DIO 

FP7 Analog Input Unit FP7 Analog Input Unit Users Manual WUME-FP7AIH 

FP7 Analog Output Unit FP7 Analog Output Unit Users Manual WUME-FP7AOH 

FP7 Positioning Unit FP7 Positioning Unit Users Manual WUME-FP7POSP 

PHLS System PHLS System Users Manual WUME-PHLS 

Programming Software 
FPWIN GR7 FPWIN GR7 Introduction Guidance WUME-FPWINGR7 

 

http://industrial.panasonic.com/ac/e/dl_center/manual/
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1.1 Start up FPWIN GR7 

1.1.1 Start up FPWIN GR7 

Start up FPWIN GR7 in the following procedure. 
 

1. Click [Start] button on Windows. 
 

2. From [All Programs], go to [Panasonic-ID SUNX Control] -> [FPWIN GR7] and select 
[FPWIN GR7]. 

 
3. When FPWIN GR7 starts up, the startup menu appears on screen. 

Select one of the following three and click [OK]. 
 

 
• Create a New Project 
• Open Existing Project 
• Load a Project from the PLC 
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■ When you want to create a new project 
 
Select "Create a New Project" and click [OK] to open 
the edit screen of FPWIN GR7. 
At that time, a Program Block named "PB1" is 
created and the ladder edit screen appears. 
You can change the name of this Program Block 
later. 
 
 
 
 
■ When you want to open a saved project 
 
Select "Open Existing Project" and choose the file 
you want to open, and click [OK]. 
 
 
 
 
 
 
 
■ When you want to read a project from PLC 
 
Select "Load a Project from the PLC" and click [OK]. 
The communication with PLC starts to read a project. 
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1.2 Close FPWIN GR7 

1.2.1 Close FPWIN GR7 

To close FPWIN GR7, use one of the following procedures. 
 

(Step 1) 
From menu bar 

Select "Project" -> "Close". 
 
 
 
 
 
 
 
 

(Step 2) 
Click                     on the Function bar. 
 
 
 

(Step 3) 
Click                on the upper right corner of the screen. 
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2.1 Create a New Project 

2.1.1 Create a New Project 

To create a new project, use one of the following procedures. 
 

(Step 1) 
When FPWIN GR7 starts up,  
select "Create a New Project" and click [OK]. 

 
 
 
 
 
 
 

(Step 2) 
From menu bar 

Select "Project" -> "New". 
 
 
 
 
 
 
 
 

(Step 3) 
Click          on the tool bar. 
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After you create a new file using one of the procedures, a new project appears as shown 
below. 
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2.2 Open an Existing Project 

2.2.1 Open an Existing Project 

To open a saved project, use one of the following procedures. 
 

(Step 1) 
When FPWIN GR7 starts up 
Select "Open Existing Project" and a file to 
open, and click [OK]. 

 
 
 
 
 
 

(Step 2) 
1. From menu bar  

Select "Project" -> "Open". 
 
 
 
 
 
 
 
 
 

Or click         on the tool bar. 
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2. Select a file and click [Open] when the file selection dialog box appears. 

 
After you open a file using one of the procedures, an opened project appears as shown below. 
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2.3 Load a Project from the PLC 

2.3.1 Load a Project from the PLC 

To load a project from the PLC, use one of the following procedures. 
 

(Step 1) 
When FPWIN GR7 starts up  
Select "Load a Project from the PLC"  
and click [OK]. 

 
 
 
 
 
 
 

(Step 2) 
From menu bar  
Select "Online" 
-> "Upload from PLC (Entire Project)". 

 
 
 
 
 
 
 
 

(Step 3) 
Click         on the tool bar. 

 
 

(Step 4) 
Click                    on the Function bar. 
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Click [OK] when the read completion 
message appears. 

 
 
 
 
 
 
A project read from PLC appears as shown below. 
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2.4 Save a Project 

2.4.1 Save a Project 

FPWIN GR7 saves the following information displayed in the Project Tree as one file (project). 
■ PLC (FP7 configuration) 

Edit I/O Comment, Block comment list, Edit data 
■ Program Block (PB) 

Scan execution type, constant period execution type 
 

In addition, the created file format is "file name.fpx". 
 
Select "Save" to overwrite an existing file and save it, or select "Save as" to specify a file 
name and save it. 
 
■ Save 

To save, use the following procedure. 
 

(Step 1) 
From menu bar 

Select "Project" -> "Save". 
 
 
 
 
 
 
 

(Step 2) 
Click         on the tool bar. 
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■ Save as 

To save as, use the following procedure. 
 

1. From menu bar 
Select "Project" -> "Save as". 

 
 
 
 
 
 
 
 

2. Specify the file name and the location to save it, and click [Save]. 
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3.1 Screen and Menu of FPWIN GR7 

3.1.1 Screen and Menu of FPWIN GR7 

The screen of FPWIN GR7 consists of the following elements. 

Menu bar

Tool bar

Project Tree

When you place the cursor on here, each window is displayed.  
 
■ Menu bar 

 
All operations and functions of FPWIN GR7 are provided in the menu format according to 
each purpose. 

 
■ Tool bar 

 
Frequently-used functions with FPWIN GR7 are organized as buttons. 
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■ Project Tree 

It refers to the window displayed on the right side 
of the screen. 
It displays a list of components and information 
saved in this project. 

 
 
 
■ Function bar 

 
You can select instructions and functions with the mouse and the function keys when 
inputting a program. 

 
■ Entry bar 

 
You can input numeric values with the mouse and select functions of Enter, Insert, Delete, 
or Escape. 

 
■ Output window 

It refers to the window displayed at the 
bottom of the screen. 
It displays a program conversion history, 
error description, and search result of 
the program. 

 
 
 
 
 
 

When you click here, the window is displayed.
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3.2 Project Tree 

3.2.1 Project Tree 

FPWINGR7 is more than managing programs. It manages them as well as all accompanying 
information as a project. 
A project consists of configuration, comment, actual operation program, and others. These 
components and information are listed in the Project Tree of FPWIN GR7. 
The Project Tree consists of the following elements. 
 

You can configure various settings of FP7.

You can enter the comments to I/O and other devices.

You can display and enter the comments for each block.

This is a list of operation programs (PB).
They are listed by execution type.
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4.1 Program Block Overview 

4.1.1 Program Block Overview 

You can combine several programs as a whole program with FPWIN GR7. 
In this case, one program is referred as a Program Block (PB). 
You can specify an execution order and download a registered Program Block to PLC. 
There are two following types of Program Blocks and the execution timing depends on where 
to register them. 
 
■ Scan execution type 

You can register a normal operation program. 
 
■ Constant period execution type 

You can register an operation program to be executed at each certain period. 
You can specify the execution period to every 1 msec or 0.1 msec. 
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4.1.2 Execution Order of a Program Block 

In addition, check the execution order before downloading a created Program Block to PLC. 
To check the execution order, use the following procedure. 
 

1. Select [Change execution order] under 
Program Block (PB) in the Project Tree 
and double-click it. 

 
 
 
 
 
Or 
Select Project (from menu bar) 

-> Program Block 
-> Change execution order. 

 
 
 
 
 

2. Check the order and click [OK] when the Change the program block (PB) execution 
order dialog box appears. 

 
 
 
 
 

 

Double-click here.

They are executed in this order.
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In addition, you can change the execution order in this dialog box. 
To change it, use the following procedure. 
 
In here, you should change the following PBs to the order of PB3 -> PB2 -> PB1. 
 

1. Open the Change the program block (PB) execution order dialog box. 
 
 
 
 
 
 

 
2. Move PB3 to the top. 

Select PB3 and click [Up] twice. 
 

 
 
 
 
 
 

 
PB3 moves to the top. 

 
 
 

Click here twice.
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3. Next, move PB1 to the bottom. 

Select PB1 and click [Down] once. 
 
 
 
 
 
 
 
 

After PB1 moves to the bottom, click [OK] to close the dialog box. 

 
 
 
 
 
 
 
 
 
 
 

Click here once.

The execution order has been changed.
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4.2 Create a New Program Block (PB) 

4.2.1 Create a New Program Block (PB) 

To create a new Program Block (PB), use the following procedure. 
1. From menu bar 

Select "Project" 
-> "Program Block" 

-> "New". 
 
 
 
 
 

Or select Program Block (PB) in the Project Tree and right-click it. 
Select [New] from the displayed context 
menu. 
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2. The Create a new program block (PB) dialog box appears. 

Input as the following and click [OK] to close the dialog box. 
 

Enter a PB name.

From pull-down menu,
select
･ Scan execution type
･ Constant period execution type
(every 1 ms or 0.1 ms).

Enter the number of steps used
for this PB (in increments of
500 steps).
If you enter 0, 500 is
automatically set.

 
 

3. A new PB is added under Program Block (PB). 

PB3 is added.
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4.3 Change the Attribute of a Program Block (PB) 

4.3.1 Change the Attribute of a Program Block (PB) 

To change name, type, and the number of steps of an existing Program Block, use the 
following procedure. 
 

1. Select Program Block (PB) from the Project Tree. 
 

From the context menu that is displayed 
by right clicking, select [Change attribute]. 

 
 
 
 
 
 
 
 
 
 
 

2. The Change PB attributes dialog box appears. 
Enter the changes and click [OK] to close the 
dialog box. 
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3. After the change, it will be reflected on the contents in the Project Tree. 

Before change After change
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4.4 Copy/Paste a Program Block (PB) 

4.4.1 Copy/Paste a Program Block (PB) 

To copy/paste a Program Block (PB), use the following procedure. 
 

1. Select a Program Block to copy and 
right-click it. 
Select [copy] from the displayed 
context menu. 

 
 
 
 
 
 
 

2. Select a destination to paste the PB 
and right-click it. 
Select [paste] from the displayed 
context menu. 

 
 
 
 
 
 
 

The copied PB is added.
At that time, the PB is
automatically named.
However, you can change
it later.
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Editing indication

The editing indication
disappears.

 
3. Edit the pasted PB. 

The icon indicating that you are  
editing it appears at the beginning of the  
PB name when the PB is pasted. 

 
 
 
 
 
 
 
 

Double-click the PB to open it and perform PB conversion after editing. 

Perform PB conversion after editing the program.

 
 

After you do the conversion, the icon 
at the beginning of the PB name 
indicating that you are editing it 
disappears. 
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5.1 Basic Operation 

5.1.1 Basic Operation 

This section uses the following circuit as an example to describe the procedure to input a 
program. 

 
 
(Program behavior: Turning on the input X100 makes the output Y100 turn on.) 
 
To input a program, click each instruction icon on the Function bar at the bottom of the screen 
with the mouse or use the function key that the instruction is assigned on the keyboard. 
 

5.1.2 Input an Instruction with Function bar (Mouse Operation) 

■ Input the contact point X100 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 
 

1. Click                   on the Function bar. 
The A contact point sign "???" appears on the network as shown below. 

 
 
 

 
2. The display on the Function bar changes, then click                . 

"X??" appears above the A contact point as shown below. 
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3. Input <1> <0> <0> with the keyboard and press <Enter> key to accept it. You have input 

successfully the A contact point of X100 as shown below. 
 
 
 
 
 

 

■ Input the coil Y100 
1. Place the cursor at the right of the A contact point of X100 and click                   on the 

Function bar. 
The coil sign "???" appears on the network. 

 
 
 
 

 
 

2. The display on the Function bar changes, then click                  . 
"Y??" appears above the coil as shown below. 

 
 
 
 
 

 
3. Input <1> <0> <0> with the keyboard and press <Enter> key to accept it. 

You have input successfully the coil of Y100 as shown below. 
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5.1.3 Input an Instruction with Keyboard 

■ Input the contact point X100 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 
 

1. Press <F1> key on the keyboard to display the A contact point sign "???" on the network. 
 
 

 
2. Then, input <X> -> <1> <0> <0> with the keyboard and press <Enter> key to accept it. 

You have input successfully the A contact point of X100 as shown below. 
 
 
 
 
 

■ Input the coil Y100 
1. Place the cursor at the right of the A contact point of X100 and press <F4> key on the 

keyboard to display the coil sign "???" on the network. 
 
 
 
 

 
2. Then, input <Y> -> <1> <0> <0> with the keyboard and press <Enter> key to accept it. 

You have input successfully the coil of Y100 as shown below. 
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5.1.4 Input a Sample Program 

This section describes the procedure to input the following sample program. 
 

■ Input AND circuit 

 
(Program behavior: Turning on the input X100 and X101 make the output Y101 turn on.) 
 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 

 
1. Input the A contact point of X100. 

Input with the mouse operation 
                     ->                   -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <0> -> <Enter> 
 

2. Input the A contact point of X101 at the right of X100. 
Input with the mouse operation 
                     -> <1> <0> <1> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <1> -> <Enter> 
 
3. Input the coil of Y101 at the right of X101. 

Input with the mouse operation 
                      ->                   -> <1> <0> <1> -> <Enter> 
Input with the keyboard 

<F4> -> <Y> -> <1> <0> <1> -> <Enter> 
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■ Input OR circuit 

 
(Program behavior: Turning on the input either X100 or X101 makes the output Y102 turn on.) 
 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 
 

1. Input the A contact point of X100. 
Input with the mouse operation 
                     ->                   -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <0> -> <Enter> 
 

2. Input the coil of Y102 at the right of X100. 
Input with the mouse operation 
                     ->                   -> <1> <0> <2> -> <Enter> 
Input with the keyboard 

<F4> -> <Y> -> <1> <0> <2> -> <Enter> 
 

3. Input the OR contact point of X101 below X100. 
Input with the mouse operation 
                     ->                   -> <1> <0> <1> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <1> -> <Enter> 
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4. Move the cursor to the right of X101. 

Input a vertical line there to connect X100 
and X101 in parallel. 

 
 
 
 
 

Input with the mouse operation -> 
                   Input with the keyboard -> <F3> 

 
 
 
 
 
 
 

 
 

Input a vertical line here.
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■ Input the self-holding circuit 

 
 
Program behavior: Turning on the input X100 makes the output Y103 turn on. After that, the 

output Y103 holds the on status even if the input X100 is turned off. 
Turning on the input X101 makes the output Y103 turn off (clear self-
holding). 

 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 
 

 
1. Input the A contact point of X100. 

Input with the mouse operation 
                     ->                   -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <0> -> <Enter> 
 

2. Input the DF (differentiate up) instruction at the right of X100. 
Input with the mouse operation <Shift> +                   -> -> <Enter> 
Input with the keyboard <Shift> + <F3> 

 
3. Input the B contact point of X101 at the right of DF. 

Input with the mouse operation 
                     ->                   ->                   -> <1> <0> <1> -> <Enter> 
Input with the keyboard 

<F1> -> <F8> -> <X> -> <1> <0> <1> -> <Enter> 
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4. Input the coil of Y103 at the right of the B contact point of X101. 

Input with the mouse operation 
                    ->                   -> <1> <0> <3> -> <Enter> 
Input with the keyboard 

<F4> -> <Y> -> <1> <0> <3> -> <Enter> 
 

5. Input the A contact point of Y103 below the A contact point of X100. 
Input with the mouse operation 
                    ->                   -> <1> <0> <3> -> <Enter> 
Input with the keyboard 

<F1> -> <Y> -> <1> <0> <3> -> <Enter> 
 

6. Input a horizontal line at the right of the A contact point of Y103. 
Input with the mouse operation ->   
Input with the keyboard -> <F7> 

 
7. Input a vertical line to connect X100 and Y103 in parallel. 

Input with the mouse operation ->   
Input with the keyboard -> <F3> 
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■ Input the timer circuit 

 
 
Program behavior: Turning on the input X100 makes the output Y104 turn on in two seconds. 

Timer TMX: 0.1-second timer, U20: set value (two seconds) 
 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 

1. Input the A contact point of X100. 
Input with the mouse operation 
                    ->                   -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <0> -> <Enter> 
 
2. Input the timer instruction (TMX0, U20) at the right of X100. 

Input with the mouse operation 
                    ->                   -> <0> -> <Enter> 

         -> -> <2> <0> -> <Enter> 
Input with the keyboard 

<F5> -> <F1> -> <0> <0> <0> -> <Enter> 
<Ctrl> + <F4> -> <2> <0> -> <Enter> 

 
(The timer coil moves to the right end after the conversion.) 
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3. Input the A contact point of T0 at the left end on the network 2. 

Input with the mouse operation 
                    ->                   -> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <T> -> <0> -> <Enter> 
 

4. Input the coil of Y104 at the right of the A contact point of T0. 
Input with the mouse operation 
                    ->                   -> <1> <0> <4> -> <Enter> 
Input with the keyboard 

<F4> -> <Y> -> <1> <0> <4> -> <Enter> 
 
 
 
 
 
 

 
The timer coil moves to the right end after the conversion. 
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■ Input the counter circuit 

 
 
Program behavior: Turning on the input X100 five times makes the output Y105 turn on. 

Turning on the input X101 makes the count value reset. 
CT: counter, U5: set value (five times) 

 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 

1. Input the A contact point of X100. 
Input with the mouse operation 
                    ->                   -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <0> -> <Enter> 
 

2. Move the cursor below X100 and input the A contact point of X101. 
Input with the mouse operation 
                    ->                   -> <1> <0> <1> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <1> -> <Enter> 
 



5.1 Basic Operation 

 
5-13 

 
3. Move the cursor to the right of the A contact point of X100 and input the counter 

instruction (CT0, U5). 
Input with the mouse operation 
                    ->                   -> <0> -> <Enter> 
                          -> <5> -> <Enter> 
Input with the keyboard 

<F5> -> <F6> -> <0> -> <Enter> 
<U> -> <5> -> <Enter> 

 
 
 
 
 
 

4. Input the A contact point of C0 at the left end on the network 2. 
Input with the mouse operation 
                    ->                   -> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <C> -> <0> -> <Enter> 
 

5. Input the coil of Y105 at the right of the A contact point of C0. 
Input with the mouse operation 
                    ->                  -> <1> <0> <5> -> <Enter> 
Input with the keyboard 

<F4> -> <Y> -> <1> <0> <5> -> <Enter> 
 
The counter coil moves to the right end after the conversion. 
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5.1.5 Input an Applied Instruction 

To input an applied instruction that performs an operation of numerical data, use the following 
procedure. 
This section describes the procedure to input data transmission instruction (MV instruction) as 
shown below. 
 

 
 
Program behavior: Turning on the input X100 transmits the value of DT100 to DT200. 
 
Place the cursor at the left end of the network and input it in the following procedure. 

 
 

1. Input the A contact point of the execution condition X100. 
Input with the mouse operation 
                    ->                   -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<F1> -> <X> -> <1> <0> <0> -> <Enter> 
 
2. Input an applied instruction (Func instruction). 

Click                     on the Function bar. (Or press <F6> on the keyboard.) 
The following Instruction list (Func) appears. 
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3. Select an instruction to use from this dialog box. 

In here, you should select [MV], [SS] (16-bit signed data transmission). 
 

Classification:
Data transfer
instructions

Instruction: MV
SS: 16-bit signed integer

Click [Save] after selection.

 
 
 
 
 

 
4. Input transmission source (DT100) in the first "???" and press <Enter>. 

Input with the mouse operation 
                    -> <1> <0> <0> -> <Enter> 
Input with the keyboard 

<D> -> <1> <0> <0> -> <Enter> (Input only D.) 
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5. Then input transmission destination (DT200) in the second "???" and press <Enter>. 

Input with the mouse operation 
                    -> <2> <0> <0> -> <Enter> 
Input with the keyboard 

<D> -> <2> <0> <0> -> <Enter> 
 

 
 
The block of an applied instruction moves to the right end after the conversion. 
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In addition, inputting the initial character of an instruction word in the Instruction list (Func) 
allows you to easily select an instruction. 

 
1. Input the initial character of an instruction word to input, "M", in the blank field of the 

Instruction list (Func), select [MV] from the displayed candidates, and press <Enter>. 
 
 
 
 
 
 
 

2. Then, input the operation unit "SS", select [SS] from the displayed candidate, and press 
<Enter>. 

 
 
 
 
 
 
 

3. After that, input the operand (DT100) and press <Enter>. 
 
 
 
 
 
 
 

After the input data appears as shown below, input the operand (DT200) in the second 
"???" and press <Enter>. 

 
 
 
 

Input "M" directly in this blank
field and select [MV] from
the displayed candidates.

Input "SS" directly in this blank
field and select [SS] from
the displayed candidate.

Input "DT100".
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You can also input an instruction word and an operand directly as text in the Instruction list 
(Func). 
 

Example: In case of inputting the following transmission instruction 
 

 
 
Input the following in the blank field of the Instruction list (Func) and press <Enter>. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Use single-byte alphanumeric characters for instruction words and operands. 
Both uppercase and lowercase characters input are available. 

 

mv.ss dt100 dt200

Instruction word.Operation unit

Single-byte spaces

Operand
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5.2 Convert a Program 

5.2.1 Convert a Program 

After input/correct a program, it is required to perform the program conversion to convert the 
program into an executable code (which PLC can understand) of the sequence program. 
After performing the program conversion, the background color of the program turns from gray 
into white. 
 
(Before the conversion) The background color of the program is gray. 

 
 
(After the conversion) The background color of the program turns white and the number of 
steps appears in the network header. 

 
 
There are following two types of the program conversion: conversion of a Program Block that 
you are editing and conversion of all Program Blocks in a project. 
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5.2.2 Convert a Program Being Edited (Offline) 

■ PB conversion 
You can convert a program that you are editing in a Program Block. 

 
 
To convert a program, use one of the following procedures. 

(Step 1) 
From menu bar 

Select "Convert" -> "Convert PB". 
 

(Step 2) 
Click        on the tool bar. 

 
(Step 3) 

Click                    on the Function bar. 
 

(Step 4) 
Press <Ctrl> + <F1> on the keyboard. 

 
When a program is successfully converted, the background color of the program changes and 
the first address of each network appears in the network header. 
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5.2.3 Convert a Program during Online Editing 

This section describes the program conversion during online editing. 
 
If you edit a program in online editing and perform program conversion, the message appears 
as shown below. 
Click [Yes] to transmit the program to PLC after converting program. 
 
 
 
 
 
 
 
 
Only a newly converted program is transmitted this time. 
(Note that a whole program is not transmitted.) 
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5.2.4 Convert the Whole Project 

■ Convert all programs 
You can convert programs of multiple Program Blocks that you are editing in a project 
collectively. 
 
To convert two Program Blocks, PB1 and PB2, collectively as shown below, use the following 
procedure. 

 
 

1. From menu bar 
Select "Convert" -> "Convert Project". 
 
 
Or click         on the tool bar. 
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2. When a confirmation dialog box is displayed, click [Yes]. 

 
 
 
 
 
 
 
 
 

3. After completing conversion, when a message as shown below is displayed, click [OK]. 
 
 
 
 
 
 
 
 
 
When the conversion completes, the background color of two Program Blocks turn white. 
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5.2.5 Designate Not to Be Converted 

■ Designate network not to be converted 
If there is a network that does not need to be converted in a Program Block that you are 
editing, you can designate it not to be converted. 
 
The following describes the procedure to designate the network 2 of the program not to be 
converted. 
 
Designate it in the following procedure. 
 

1. Click the network header of the network 2 to select it. 

 

Click here (network header).
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2. From menu bar 

Select "Edit" -> "Target/detarget this network for 
conversion". 

 
Or 
 
Select "Target/detarget this network for conversion" 
from the context menu that is displayed by right clicking. 

 
 
 
 

3. The "X" mark appears in the network header designated not to be converted. 
 
 
 
 
 
 
 
 
 
 

 
4. Perform the program conversion. 

 
 
 
 
 
 
 
 
 
 

As shown above, the program conversion does not convert the network 2 that is designated 
not to be converted. 
Even if you download programs to PLC in this condition, the network 2 is not downloaded. 
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■ Designate a Program Block not to be converted 
You can also make Program Block (PB) an exception of conversion in a project that does not 
need to be converted. 
To designate PB2 not to be converted, use the following procedure. 
 
 
 
 
 
 
 
 
 
 
 

1. Select PB2 from the Project Tree. 
 
 
 
 
 
 
 
 

2. Then select  
"Target/detarget this network for 
conversion" from the context menu that 
is displayed by right clicking. 

 
 
 
 
 
 
 

Designate this
Program Block (PB2)
not to be converted.
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3. When a confirmation message dialog box as shown below is displayed, click [Yes]. 

 
 
 
 
 
 
 
 

4. After the Program Block is designated not to be converted, the display of the Project 
Tree changes as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 

The operation program in the Program Block (PB) designated not to be converted is not 
transmitted to PLC. 

The red       mark is added
at the beginning of the PB
name that is not converted.
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5.2.6 Designate Not to Be Executed 

■ Designate the network not to be executed 
If there is a network that does not need to be executed in a Program Block that you are editing, 
you can designate it not to be executed. 
 
The following describes the procedure to designate the network 3 of the program not to be 
executed. 
 
Designate it in the following procedure. 
 

1. Click the network header of the network 3 to select it. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. From menu bar 
Select "Edit" -> "Target/detarget this network for 
execution". 

 
Or 
 
Select "Target/detarget this network for execution" 
from the context menu that is displayed by right 
clicking. 

 

Click here (network header).



5.2 Convert a Program 

 
5-29 

 
3. The "/" mark (oblique line) appears in the network header designated not to be executed. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
4. Transmit a program to PLC. 

 
 
 
 

 
 
 
 
 
 
 
 
 
 

This part of the program is converted, but not executed. 
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■ Designate a Program Block not to be executed 
You can also make Program Block (PB) an exception of execution in a project that you do not 
want to execute. 
To designate PB2 not to be executed, use the following procedure. 

 
 
 
 
 
 
 
 
 
 
 
 

 
1. Select PB2 from the Project Tree. 

 
 
 
 
 
 
 
 
 

2. Then select  
"Target/detarget this PB for execution" 

from the context menu that is 
displayed by right clicking. 

 
 

 
 

Designate this
Program Block (PB2)
not to be executed.
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3. When a confirmation message dialog box as shown below is displayed, click [Yes]. 

 
 
 
 
 
 
 
 
 

4. After the Program Block is designated not to be converted, the display of the Project 
Tree changes as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 

 
The operation program in the Program Block (PB) designated not to be executed is 
transmitted to PLC, but not executed. 

The yellow mark is added
at the beginning of the PB
name that is not converted.
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5.3 Edit a Program 

5.3.1 Edit a Program 

 
This section uses the following program as an example to describe program modification, 
addition and deletion. 

 
 

5.3.2 Add/Insert an Instruction 

■ Add an instruction 
To add a contact point on the horizontal line, input a contact point in the normal procedure. 
There is no need to delete the horizontal line. 
 

1. Place the cursor on the position to add a contact point. 
 
 
 
 
 
 

 
2. In here, add the A contact point of R300. 

Input the A contact point of R300 with the mouse operation or the keyboard and press 
<Enter> key to overwrite the selected position with the contact point. 

 
Refer to 5.1.2 and 5.1.3 for the information on how to input a contact point. 
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■ Insert an instruction 
You can insert a contact point before an instruction that has already been input. 
In here, insert the A contact point of X100 before the contact point of X110 at the beginning. 
 
1. Place the cursor on the position to insert a contact point. 

 
 
 
 

 
 
2. Input the A contact point of X100 with the mouse operation or the keyboard. 

 
 

 
3. After input, press <Insert> key to accept it. The A contact point of X100 is inserted 

before the given position. 
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5.3.3 Delete Instruction/Horizontal Line/Vertical Line 

■ Delete instruction and horizontal line 
When you wish to delete an instruction or a horizontal line, place the cursor on the desired 
position and click <Delete> key. In here, you should delete the contact point of X110. 

 
1. Place the cursor on the position of instruction you wish to delete. 

 
 
 
 
 
 

 
2. Press <Delete> key to delete the selected instruction (horizontal line). 

 
 
 
 
 
 

 
3. After deleting the line, write other instructions or draw a horizontal line to fill the blank 

portion. 
 
 
 
 
 
 
 

Or, you can also delete an instruction by placing the cursor on the position you wish to delete 
then enter (or overwrite) a horizontal line                   . 

Do not leave the deleted portion blank.
Input a horizontal line or a different instruction.
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■ Delete vertical line 
When you wish to delete a vertical line, place the cursor at the right of the vertical line you 
wish to delete, and either click                   , or press <F3> key to delete it. 

 
1. Place the cursor at the right of the vertical line you wish to delete. 

 
 
2. Either click                   , or press <F3> key to delete it. 

 
 
 
 

Move the cursor to the right of the
vertical line you wish to delete.

The vertical line has been deleted.
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5.3.4 Change the Contact Point Number and the Timer Set Value 

■ Change the contact point number and the coil number 
Place the cursor on the position of the contact point or the coil you wish to change, and 
enter the relay number with the keyboard. 

 
(Example 1) Change the relay number of the contact point from R300 to R100. 

 
 
 
 

 
1. Place the cursor on the position (of the contact point or the coil) you wish to change. 

 
 
 
 
 
 

 
2. Enter the new number (100) with the keyboard. 

 
 
3. Press <Enter> to change the relay number. 

 
 
 
 
 
 

Change it to R100.
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(Example 2) Change the relay number of the coil from R200 to Y100. 

 
 

1. Place the cursor on the position you wish to change. 
 
 
 
 
 
 

 
2. Enter the new type and the number of the relay. 

Enter <Y> with the keyboard. (Type of relay) 

 
 

Then enter <1> <0> <0> with the keyboard or the numeric keypad. (Number) 

 
 

 
3. Press <Enter> key to change the relay number. 
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■ Change the timer set value 
Place the cursor on the position of the timer set value you wish to change, and enter the 
new set value. 
In here, you should change the timer set value from U10 to U20. 

 
 
 

1. Place the cursor on the set value you wish to change. 
 
 
 
 
 

 
2. Enter the new set value <2> <0> with the keyboard. 

 
 

 
 
3. Press <Enter> key to change the set value. 

 
 



5.3 Edit a Program 

 
5-39 

5.3.5 Change Contact Point Type 

Change A contact point of X100 to B contact point as shown below. 

Change the A contact point to the B contact point.

 
 
To change A contact point -> B contact point, and B contact point -> A contact point, use the 
following procedure. 

 
1. Place the cursor on contact point you wish to change. 

 
 
 
 
 

2. Click                   on the Function bar and press <Enter> key to change A contact point to 
B contact point. 

 
 
 
 
 

Similarly, when changing B contact point -> A contact point, place the cursor on B contact 
point you wish to change and click                   to change it. 
In place of                   , you can also change using </> key. 
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5.3.6 Insert and Delete a Blank Line 

To insert or delete a blank line in the network, use the following procedure. 

■ Insert a blank line 
 
 
 
 
 
 
 
 
 
 

 
1. Place the cursor on the position you want to insert a blank line. 

 
 
 
 
 
 

 
2. Insert a blank line. 

When you select "Edit" -> "Insert a Rung" from menu bar, a blank line is inserted. 
 
Insert a Rung also can be carried out in the following procedure. 
• From the context menu that is displayed by right clicking, select "Insert a Rung". 
• Press <Ctrl> + <Insert> on the keyboard. 

 
 
 
 

Insert a blank line into              .
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■ Delete a blank line 

Delete the blank line of                 .

 
 

1. Place the cursor on the position you want to delete a blank line. 
 
 
 

 
 
 
 
 

 
2. Delete a blank line. 

From menu bar, select "Edit" -> "Delete a Rung". 
 
Delete a Rung also can be carried out in the 
following procedure. 
• From the context menu that is displayed by right 

clicking, select "Delete a Rung". 
• Press <Ctrl> + <Delete> on the keyboard. 
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A blank line is deleted as shown below. 
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5.3.7 Insert Network/Delete Network 

Insert Network/Delete Network is to be carried out in the following procedure. 
 

■ Insert Network 
Insert a new network between network 1 and network 2. 

 
 

1. Place the cursor on the network 2. 
 
 
 
 
 
 

 
2. Insert a network. 

From menu bar 
Select "Edit" -> "Insert Network". 
You can also insert a network in the following 
procedure. 
• From the context menu that is displayed by right 

clicking, select "Insert Network". 
• Press <Shift> + <Insert> on the keyboard. 
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Then a new network is inserted as shown below. 
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■ Delete Network 
Delete network 2 in the figure below. 

 
 

1. Place the cursor on the network to be deleted (Network 2 in here). 
 
 
 
 
 
 
 
 

 
 
2. Delete the network. 

From menu bar, select "Edit" -> "Delete Network". 
 
You can also delete a network in the following 
procedure. 
• From the context menu that is displayed by right 

clicking, select "Delete Network". 
• Press <Shift> + <Delete> on the keyboard. 
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Network 2 will be deleted. 
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In addition, you can delete a network in the following procedure. 
 

1. Select the network you wish to delete by clicking its network header with the mouse. 
 
 
 
 
 
 
 
 

 
2. Press the [Delete] key to delete the network. 
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5.3.8 Copy/Cut/Paste an Instruction 

To copy/cut/paste an instruction, use the following procedure. 
You can paste an instruction to other networks. 

■ Copy/paste at a single point 
1. Place the cursor on the instruction you wish to copy. 

 
 
 
 
 
 

 
2. Copy it. 

From menu bar, select "Edit" -> "Copy". 
You can also copy it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Copy". 
• Press <Ctrl> + <C> on the keyboard. 

 
 
 

3. Paste it. 
Move the cursor to the location you wish to paste, and 
select "Edit" -> "Paste" from menu bar. 
You can also paste it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Paste". 
• Press <Ctrl> + <V> on the keyboard. 
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■Cut/paste at a single point 
1. Place the cursor on the instruction you wish to cut. 

 
 
 
 
 
 

 
2. Cut it. 

From menu bar, select "Edit" -> "Cut". 
You can also cut it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Cut". 
• Press <Ctrl> + <X> on the keyboard. 

 
 
 
 

3. Paste it. 
Move the cursor to the location you wish to paste, 
and select "Edit" -> "Paste" from menu bar. 
You can also paste it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Paste". 
• Press <Ctrl> + <V> on the keyboard. 
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■ Copy/paste at multiple points 
1. Select the parts in an instruction you wish to copy by dragging the mouse. 

 
 
 
 
 

2. Copy it. 
From menu bar, select "Edit" -> "Copy". 
You can also copy it in the following procedure. 
From the context menu that is displayed by right 
clicking, select "Copy". 
Press <Ctrl> + <C> on the keyboard. 

 
 
 
 

3. Paste it. 
Move the cursor to the location you wish to paste, 
and select "Edit" -> "Paste" from menu bar. 
You can also paste it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Paste". 
• Press <Ctrl> + <V> on the keyboard. 

 
 
 

 
 
 
 
 
 

Cutting is to be performed by the same manner as cutting at a single point. 
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5.3.9 Copy/Cut/Paste a Network 

To copy/cut/paste each network, use the following procedure. 
 

■ Copy/paste 
1. Select a network you wish to copy. 

 
 

 
2. Copy it. 

From menu bar, select "Edit" -> "Copy". 
You can also copy it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Copy". 
• Press <Ctrl> + <C> on the keyboard. 

 
 
 
 
 

3. Paste it. 
Move the cursor to the location you wish to paste, and 
select "Edit" -> "Paste" from menu bar. 
You can also paste it in the following procedure. 
• From the context menu that is displayed by right 

clicking, select "Paste". 
• Press <Ctrl> + <V> on the keyboard. 
 
 
 

 
 

Cutting is to be performed by the same manner. 
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5.4 Other Edite Functions 

5.4.1 Change (Replace) a Device 

You can change multiple types and numbers of contact points in a program at once. 
Note that you can also change the corresponding I/O comments at the same time. (You 
cannot change explanatory comments.) 
 

■Change at a single point 
You change all R100s in a program to R200s as shown below. 

Change them to R200.

 
 

1. From menu bar 
Select "Search/replace" -> "Replace". 

 
 
 
 
 
 

2. When "Search/replace" dialog box is displayed, specify the following items. 
• Device before replacement 
• Number of replacements 
• Device after replacement 
• Replacement range 
• Replacement direction 
• Options (Also move I/O comments etc.), Special replacement 
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In here, you should enter as shown below, and press [Replace All(A)]. 

If you wish to replace
the I/O comment at the
same time, check this
item.

When this item is
checked, the display
color of a device to be
replaced will change.

 
 
 

3. Then a message as shown right will be displayed. 
Click [Yes(Y)] to perform replacement. 

 
When you don't put check mark on 
the option "Also move I/O 
comments" this message will not be 
displayed. 

 
 
 
 

After the replace is completed, a message as 
shown right will be displayed. 
Close the dialog box by clicking [OK]. 

 
 
 

Finally click [Close] to close the Replace dialog box. 
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R100 has been changed to R200.
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5.4.2 Continuing Input 

When you want to input a ladder diagram that cannot be written in one line, you can input 
it over multiple lines. 
In this case, enter "Continuing" at the point the line is wrapped. 
The one entered before the bus bar at the right end is called "Continuing output", and the 
one that connects to bus bar at the left end of the wrapped line is called "Continuing 
input". 
The same number is assigned to the "Continuing output" and the "Continuing input" so 
that you can specify from where to where the line wrapping occurs. 
 

Continuing output

Continuing input
 

 
There are following two types of Continuing Input. 
• Enter Continuing Pair: "Continuing output" and "Continuing input" are entered as a pair. 
• Enter Continuing Symbol: "Continuing output" or "Continuing input" is designated as a 
single entry. 
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■ Input Continuing Pair 
"Continuing output" and "Continuing input" are entered as a pair. 
Here described the procedure how to input in wrapping lines as shown below. 

 
 
 
 

1. From menu bar 
Select "Edit" -> "Input Continuing Pair". 

 
 
 
 
 
 
 
 
You can also input in the following procedure. 
• Select         on the tool bar. 

 
 
• From the context menu that is displayed by 

right clicking, select "Input Continuing Pair". 
 

2. Continuing number dialog box appears. 
Specify the number and click [OK]. 
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3. Specify the Continuing output position (Continuing starting position). 

Place the cursor on the Continuing output position and click <Enter>, or specify the 
position by clicking the mouse. 

 
 
 
 
 

 
4. Specify the Continuing input position (destination of Continuing). 

Place the cursor on Continuing input position (on the left of the next line) and press 
<Enter>, or specify the position by clicking the mouse, then the specified number of 
"Continuing output" and "Continuing input"are inputted as a pair.
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■ Input Continuing Symbol 
"Continuing output" or "Continuing input" is entered as a single entry. 
Here described the procedure how to input in wrapping lines as shown below. 

 
 

1. Place the cursor on the Continuing output position (Continuing starting position), or click 
with the mouse. 

 
 
 
 

 
2. From menu bar 

Select "Edit" -> "Input Continuing Symbol". 
 
You can also Input in the following procedure. 
From the context menu that is displayed by right 
clicking, select "Input Continuing Symbol". 

 
 
 
 
 

3. Continuing number dialog box appears. 
Specify the number and click [OK]. 

 
 
 

4. "Continuing output" with the specified number is inputted. 
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5. Place the cursor on the Continuing input position (destination of Continuing), or click 

with the mouse. 
  
 
 
 

 
 

6. From menu bar 
Select "Edit" -> "Input Enter Continuing Symbol". 

 
You can also input in the following procedure. 
From the context menu that is displayed by right clicking, 
select "Input Continuing Symbol". 

 
 
 
 

7. Continuing number dialog box appears. 
Specify the number and click [OK]. 

 
 
 

8. "Continuing input" with the specified number is inputted. 
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5.4.3 Revert to Just after Last Program Conversion 

Immediately after executing a conversion of a program, you can cancel the conversion and 
restore the state to immediately after the conversion. 
 

1. Change a program as follows. 
 
 
 
 
 
 
 
 
 
 

 
2. Perform the conversion. 

 
 

3. Restore the state to before the conversion. 
From menu bar 
Select "Edit" -> "Revert to Just after Last Program 

Conversion". 
Or select "Revert to Just after Last Program 
Conversion" from the context menu 
 that is displayed by right clicking. 
 
 

Change the program.

Perform the conversion.
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4. This will restore the state of immediately after the conversion as shown below. 
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 6 
 Transmit a Program 
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6.1 Switch Editing Mode (online editing/offline 
editing) 

6.1.1 Switch Editing Mode (online editing/offline editing) 

The program editing mode for FPWIN GR7 has two modes. 
One is offline editing mode where you edit the program only on PC screen without 
communication with PLC, and the other on is online editing mode where you edit it with 
always communicating with PLC. 
You can immediately write the programs inputted during online editing and the changes of 
system registers without downloading them first to PLC. 

6.1.2 Switch to Online Mode 

To switch to online mode, use the following procedure. 
 

(Step 1) 
From menu bar  
Select "Online" -> "Switch to Online Mode". 

 
 
 
 
 
 
 
 

(Step 2) 
Click         on the tool bar. 

 
 
 

(Step 3) 
Click                  on the Function bar. 

 
 

(Step 4) 
Press <Ctrl> + <F2> on the keyboard. 
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6.1.3 Switch to Offline Mode 

To switch to offline mode, use the following procedure. 
 
(Step 1) 
From menu bar 
Select "Online" -> "Switch to Offline Mode". 
 
 
 
 
 
 
 
 
 
(Step 2) 
In online 
Click         on the tool bar. 
 
 
 
(Step 3) 
Click                   on the Function bar. 
 
 
   
(Step 4) 
Press <Ctrl> + <F3> on the keyboard. 
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6.2 Write a Program to PLC 

6.2.1 Write a Program to PLC 

To download the created program and the comment to PLC, use the following procedure. 
 

(Step 1) 
From menu bar 
Select "Online" -> "Download to PLC (Entire 
Project)". 
 
 
 
 
 
 
 
 
(Step 2) 
Click           on the tool bar. 
 
 
 
(Step 3) 
Click                     on the Function bar. 
 
 
 
(Step 4) 
Press <Ctrl> + <F12> on the keyboard. 
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If downloading is successfully completed by either way, the dialog box shown below is 
displayed. 
To switch to the RUN mode, click on the “Yes” button, other way click “No” button. 
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6.3 Upload a Program from PLC 

6.3.1 Upload a Program from PLC 

Read out the program and the comment from PLC main unit to FPWIN GR7. 
To read out them, use the following procedure. 
 

(Step 1) 
From menu bar  
Select "Online" -> "Upload from PLC (Entire 
Project)". 
 
 
 
 
 
 
 
 
 
(Step 2) 
Click        on the tool bar. 
 
 
 
(Step 3) 
Click                   on the Function bar. 
 
 
 
(Step 4) 
Press <Ctrl> + <F11> on the keyboard. 
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When the uploading is completed by either way, the confirmation message appears as 
shown below. 
Click [Yes] to start uploading. 
 

 
 
 
 
 
 
 

 
When the uploading is completed, a message appears as shown below. 
Close the dialog box by clicking [OK]. 
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6.4 Switch PLC Operating Mode 

6.4.1 Switch PLC Operating Mode 

In online mode, you can switch the operation mode of PLC (RUN mode, PROG mode) from 
FPWIN GR7. 
For FP7, the mode can be switched regardless which side the mode change switch of the 
main unit is positioned at. 
The operation mode is to be switched in the following procedure. 
 

(Step 1) 
From menu bar 
Select "Online" -> "Switch PLC Operating 
Mode". 
 
 
 
 
 
 
 
 
(Step 2) 
Click          on the tool bar. 
 
 
 
(Step 3) 
Click                    on the Function bar. 
 
 
 
(Step 4) 
Press <Ctrl> + <F9> on the keyboard. 
Or 
Press <Ctrl> + <D> on the keyboard. 
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7.1 Clear Program 

7.1.1 Clear Program 

To delete a program that was created, use the following procedure. 
 

1. From menu bar 
Select "Edit" -> "Clear Program". 

 
 
 
 
 
 
 
 
 

 
2. When a confirmation message is displayed, click [Yes(Y)]. 

 
 
 
 
 
 
 
 

 
 

3. After deletion, a message of completion is displayed. Click [Yes] to close the dialog box. 
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In addition, when there are multiple PBs, although the programs in those PBs are deleted, the 
PB themselves will not be deleted. 
 

 
The number of program steps in each PB will be 0 step, as shown below. 
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To delete a PB itself, use the following procedure. 
 

1. Select an unnecessary PB in the Project Tree window. 
 
From the context menu that is displayed 
by right clicking, select "Delete". 

 
 
 
 
 
 
 
 
 
 

2. When a message as shown below is displayed, click [Yes] to close the dialog box. 
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8.1 Check a Project 

8.1.1 Check Entire Project 

Error checking for the project of PLC main unit is to be conducted. 
This function operates when in online mode and PLC is in Prog. mode. 
 
Since there are possibilities of the following errors in the following program, these errors will 
be detected using the total check function. 

Duplicated

Insufficient pair

 
 

1. From menu bar  
Select "Debug" -> "Check Entire Project". 

 
 
 
2. When a dialog box as shown right is displayed, click [Execute]. 
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3. When some errors are found, both Number of errors and Error description are displayed. 
 

 
 
 
 
 

 
Duplicate use (definition) error -> This error occured in such instruction as OUT, when 

an output coil of the same No. is used twice, or the 
same No. is used in timer/counter. 
In here, the error occured because two output coils of 
R100 are used. 

Pair mismatch error -> This error occured when one piece of a paired instruction is 
absent. 
In here, the error occured because the instruction set MC and 
MCE that are supposed to be used as a pair lacks MCE. 

 
 

4. When you wish to confirm the position where an error occurred, select the error you 
wish to check and click [Jump], and the cursor will move to the position of the error. 

 
 
 
 
 
 
 
 
 
 
 
 

 
After confirming the error, click [Close] to close the dialog box. 
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5. After confirming the error, correct the program. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
6. After correcting the error, execute the total check again. 

When there is no more error, a message as shown below will be displayed. 
Close the message by clicking [OK]. 

 
 
 
 
 
 
 
 

 
 
 

Sufficient pairChange it to R101.



8.2 Compare Projects 

 
8-5 

8.2 Compare Projects 

8.2.1 Compare Projects 

The project currently displayed is compared with a separate project in PLC main unit or a 
saved project, to examine if they match. 
Compare Projects is to be carried out in the following procedure. 
 
In here the current project is compared with the one in PLC main unit. 

 
1. From menu bar  

Select "Debug" -> "Compare Projects". 
 
 
 
 

2. Select Compare with PLC, and click [OK]. 
 
 
 
 
 

3. When a message as shown right is displayed, 
click [Yes] to upload the project. 
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4. Subsequently a message to select the 

target of the comparison is displayed. 
• Source project (left side: Untitled) 

-> Check on the box Program Block 
(PB). 

• Target project (right side: PLC) 
-> Check on the box Program Block 

(PB). 
 

Then start the comparison by clicking 
[Execute]. 

 
 
5. The Detailed comparison results dialog 

box appears. 
When there are any unmatched items, 
the portions will be displayed in red. 

 
 
 
6. Identify the unmatched portion. 

Double-click the item displayed in red. 
 

Then the details are displayed in 
different colors as shown right. 
 
Matched case -> Displayed in blue 
Unmatched case -> Displayed in red 
Non-existent instruction case -> 
Displayed in gray 
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Moreover, when you wish to identify the location of the item displayed in the dialog box, 
select the desired item, and double-click it. 
 
For example, when you wish to 
identify the location of X102 of the 
Source project, move the cursor to 
X102 as shown right and double-
click it. 

 
 
 
 
 
 
Then the cursor will move to the location of X102 in the project. 
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8.3 Force the Contact Point to ON/OFF 

8.3.1 Force I/O 

This function is to forcibly set the contact point/coil specified in the program to ON/OFF, 
regardless of the contents of the program.  
Using this Force I/O function, you can confirm the operation of an output device or a program. 
(Up to 32 points of Force I/O are allowed.) 
This function operates only in online mode and PLC is in RUN mode. 
Also during Force I/O operation, the LED of RUN on PLC main unit flickers. 
 
By forcibly setting X100 and X101 of following program to ON/OFF, the operation of the 
program is examined. 

 
 
 
 
 
 
 
 
 
 
 
 

 
1. From menu bar 

Select "Debug" -> "Force I/O". 
 
 

Force them to ON/OFF .
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2. When a dialog box as shown below is displayed, click [Enter Device] to register the input 

and output devices that are the target of forced I/O operation. 
 

 
 
 
 
 
 
 
 
 

 
 

3. To the displayed dialog box for the Force 
I/O device registration, enter as shown 
right and click [OK] to close it. 

 
• Device type -> X (external input) 
• No. -> 100 
• Number of continuous registrations -> 2 

 
 
 
 

4. The registered X100 and X101 are displayed. 
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5. Forcibly set X100 and X101 to ON, and start the program. 

First, set X100 to ON. 
Select X100 and click [ON], and the contact point of X100 will be ON. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Similarly, set X101 to ON forcibly. 

 
 

ONThe contact point is turned      .

ONThe contact point is turned      .
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6. Reset the registration of X100 and X101, and complete the Force I/O. 

Click [Release] inside the dialog box will clear the registered contents, and complete the 
Force I/O. 

 
 
 
 
 
 
 
 
 
 

 
The buttons inside the Force I/O dialog box are as follows. 
[ON] -> forcibly sets the selected contact point to ON regardless of the contents of the 

program. 
[OFF] -> forcibly sets the selected contact point to OFF regardless of the contents of the 

program. 
[FREE] -> directs the selected contact point to behave as per the contents of the 

program. 
[Release] -> releases all the registered contact points. 
[Delete] -> deletes only the selected contact points from the registration. 
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9.1 Comments Overview 

9.1.1 Comments Overview 

In FPWIN GR7, it is possible to enter comments to the created ladder program. 
There are following three types of comments that can be entered. 

I/O comment - - - - - - - - - -  The comments are entered for the devices such as input relay, 
output relay, internal relay and data register. 
The comments are displayed underneath each device. 

Remarks - - - - - - - - - - - - -  The comments are entered for the output coil. 
The comments are displayed at the position of the output coil 
(on the right side of bus bar). 

Block comments - - - - - - -   The comments are attached to the ladder program to give 
explanation for each block. 

 

Block comments

RemarksI/O comments

 
 

Also, various comments can be entered in three types. 
The example below shows the case where I/O comment are entered in type 1 -> Japanese, 
type 2 -> English and type 3 -> Chinese, and the display is switched. 
 
Type 1 -> English 
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Type 2 -> Japanese 

 
 
Type 3 -> Chinese 
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9.2 Attach a Comment to the I/O 

9.2.1 Attach a Comment to the I/O 

This function is to enter I/O Comment. 
When you wish to enter comments to multiple devices, it is convenient to use Edit I/O Comment 
function. 
Enter it in the following procedure. 
 
From menu bar  
Select "Comment" -> "Edit I/O Comment". 
 
 
 
 
 
Or double-click [Edit I/O Comment] in the 
Project Tree. 
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Dialog box of Edit I/O Comment will be displayed. 
Select the Device type to enter comments, and enter the comments in the field with the 
corresponding number. 
 
 

Enter a comment here.

Used points only -> Only devices used in a program are listed.
Unused points only -> Only devices not used in a program are listed.

Select a device to
enter the comments
from the list.

Select Global devices
or Local devices.
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The example shown right is the case where "Start SW" for X100 
and "Stop SW" for X101 are entered. 
 
The device used in the program shows * before No. 
 
 
 
 
 
 
 
 
 
 
 
By expanding the width of the dialog box, you can also display and enter all Type 1 - Type 3. 
 

When you expand
the width, you can
see all the three types.
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When I/O comments entered are to be deleted 
subsequently, click [Options] inside the Edit I/O 
Comment dialog box. 
 
 
 
 
 
 
Then the Options dialog box is displayed. 
Select the target of deletion, and click [OK]. 
 
 
 
When you wish to delete all of the entered I/O 
comments, select "Delete all points" and click [OK]. 
When a confirmation message is displayed, click  
[Yes(Y)]. 
 
 
 
 
When you wish to delete only the I/O comments for the devices that are not used in the 
program, select "Delete unused points" and click [OK]. 
When a confirmation message is displayed, click [Yes(Y)]. 
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9.3 Attach a Comment to the Output Coil 

9.3.1 Attach a Comment to the Output Coil 

Enter the "Remarks" to be attached to an output coil. 
To enter Remarks, use the following procedure. 
 

1. Place the cursor on the output you wish to attach Remarks. 
 
 
 
 
 
 

 
2. From menu bar  

Select "Comment" -> "Enter Remarks". 
 
 
 
 
 
 

3. Then Enter Remarks dialog box is displayed. 
Enter the comment and click [Register]. 

 
 
 
After entering, a comment will be displayed at the right of bus bar. 
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When you press [+] inside the Enter Remarks dialog 
box, both display and input of Type 2 and Type 3 
are enabled. 
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9.4 Attach a Comment to Each Block 

9.4.1 Attach a Comment to Each Block 

Enter the comment, "Block comments", which is attached to each block. 
To input Block comments, use the following procedure. 
 

1. Place the cursor on the first line of the block which you wish to attach the comment to. 
 
 
 
 
 
 

 
 

2. From menu bar  
Select "Comment" -> "Enter Block Comment". 

 
 
 
 
 

3. The Edit block comments dialog box is 
displayed. 
After input, click [OK] to close the dialog box. 

 
Same with the other comments, when you 
press [+] inside the Enter Remarks dialog box, 
both display and input of Type 2 and Type 3 
are enabled. 
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Above the specified block, an additional block for the comment is inserted. 
No ladder programs can be entered to the comment display block. 
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9.5 Switch Show/Hide Comments 

9.5.1 Switch Show/Hide Comments 

This allows you to switch show/hide comments on the screen. 
You can show or hide I/O comments and explanatory comments. You cannot hide the block 
comment. 
To show or hide them, use the following procedure. 
 

From menu bar  
Select "Display" -> "Show/hide comments". 

 
 
 
 

Or click          on the tool bar. 
 
The space between lines of each block is collapsed, and I/O comments and explanatory 
comments that were displayed will be hidden. 

Show comments

Hide comments
 

When you wish to display again, use the same procedure above to switch. 
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10.1 Search for Devices 

10.1.1 Search 

■ Display the search result in sequence 
You search the specified device in the program, and move the cursor to the position of its 
contact point and coil. 
To search R100 from the program below, use the following procedure. 

Search R100 in the program.

 
 

1. From menu bar 
Select "Search/replace" -> "Find". 

 
 
 
 

2. When "Search/replace" dialog box is displayed, enter as shown below. 
 

• Search target -> Device R100 
• Search range -> This program only 
• Search direction -> From beginning 
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3. After entering, when you click [Find next] button or press <Enter> key, the search is 

started, and the cursor will move to the position of the contact point or the coil that meet 
the search criteria. 

 
 
 
 
 
 

4. Then, when you click [Find next] button again or press <Enter> key, the next R100 is 
searched and the cursor will move. 

 
 

 
5. When the search is reached to the end of 

the program, the dialog box as shown right 
will be displayed. 
Press [Yes] to search again, or press [No] 
to finish the search. 

 
 
 
 
 
Using this search dialog box, you can also search only the specific type of device by 
specifying the type. 
When you specify R and search, you can search all R's used in the program in sequence. 
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■ List the search result 
Then R100 of the program below is searched, and the instructions and addresses using it will 
be listed. 

Search R100 in the program.

 
 

1. From menu bar 
Select "Search/replace" -> "Find". 

 
 
 

 
2. When "Search/replace" dialog box is displayed, enter as shown below. 

 
• Search target -> Device R100 
• Search range -> This program only 
• Search direction -> From beginning 
• Highlight search results 

 
 
 
 
 
 
When Highlight search results check box is selected, the display color of the applicable 
devices in ladder diagram are changed after the search. 
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3. After entering, click [Find All] button. 

In the Search tab in the Output window at the 
bottom of the screen, the utilization of R100 
will be listed. 

 
 
 
 
 
 

 

When you select and double-click each item,
the cursor will move to the address.
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10.1.2 Direct Device Search 

It is also possible to search a device without displaying Search dialog box mentioned earlier. 
As shown below, the R100's that are used in other positions than the R100 in network 1 
output will be searched. 

Search the R100's that are used
in other positions than the R100.

 
 

1. Place the cursor on the R100 that is used as the output of network 1. 
 
 
 
 
 
 

 
2. From menu bar  

Select "Search/replace" -> "Direct Device Search". 
 
 
 
 

You can search it by pressing <Ctrl> + <[> on the keyboard. 
 

When the search is executed, the cursor will move to the mose recently used R100. 

The cursor moves here.
 

When the search is done again, the cursor will move to the next position of R100. 
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10.2 Search for Instruction 

10.2.1 Search for Instruction 

 
Search the specified Instruction in the program. 
Search the timer instruction (TMX) used in the following program. 

Search this timer instruction (TMX0).

 
 

1. From menu bar  
Select "Search/replace" -> "Find". 

 
 

 
 
 

2. When "Search/replace" dialog box is displayed, enter as shown below. 
 

• Search target -> Instruction TMX0 
• Search range -> This program only 
• Search direction -> From beginning 
• Highlight search results 
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3. When you click [Find next], the search is started, and the cursor will move to the position 

of TMX0 used in network 2. 
When Highlight search results check box is selected, the background color of TMX0 is 
changed. 
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10.3 Search for Comment 

10.3.1 Search for Comment 

Search specified string from the Comment (I/O comment, Remarks, Block comments) in the 
program. 
In here, the string "Motor" from the following program is searched. 
 

 
 
 

1. From menu bar  
Select "Search/replace" -> "Find". 
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2. When "Search/replace" dialog box is displayed, enter as shown below. 

 
• Search target -> Comment Motor 
• Search range -> This program only 
• Search direction -> From beginning 
• Comment to search for ->  

I/O comment 
Remarks 
Block comments 

 
 
 

3. When you click [Find next], the search is started, and the cursor will move in sequence 
to the position where the string of 
Motor is present. 
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10.4 Move Cursor to the Specified Position 

10.4.1 Jump 

 
When you wish to move the cursor to the specified address or the position of a network, use 
Jump function. 
 

■ Move the cursor by specifying the address 
Move the cursor to the 10th step in the following program. 

 
 

1. From menu bar 
Select "Search/replace" -> "Jump". 

 
 
 
 

2. When the dialog box of Jump is displayed, 
enter as shown below. 
• Select Address check box, and specify 10. 

 
 
 

3. After input, when you click [Jump], the cursor will move to the 10th step of (DF) 
instruction. 
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■ Move the cursor by specifying the network No. 
Move the cursor to the top of network 4 in the following program. 

 
 

1. From menu bar 
Select "Search/replace" -> "Jump". 

 
 
 
 

2. When the dialog box of Jump is displayed, 
enter as shown below. 
• Select Network no. check box, and specify 4. 

 
 

3. After input, when you click [Jump], the cursor will move to the top of network 4. 
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10.5 Search for the Use Location of Device 

10.5.1 Cross Reference 

The addresses used by the contact point/coil/instruction of the devices that are used in the 
program are listed in Output window at the bottom of the screen. 
 
Search the addresses that are used by R100 in the following program. 

 
 

1. Place the cursor on R100 in the program. 
 
 
 
 
 
 

 
2. From menu bar  

Select "Search/replace" -> "Cross Reference". 
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3. The search result is displayed in Output window at the bottom of the screen. 
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10.6 Confirm Utilization of Device 

10.6.1 Used Device List 

The utilization of the contact point/coil/register/instruction that are used in the program is listed. 
This is used to confirm the unused devices/instructions at creating/editing a program. 
 
Search the utilization of internal relays in the following program. 

 
 
 

1. From menu bar 
Select "Search/replace" -> "Used Device List". 
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2. The list is displayed at the right of ladder edit 

screen. 
 

• Device type -> R (internal relay) 
• Devices to display -> All 
Select as shown above. 

 
All the devices without * mark mean that they 
are not in use. 

 
 
 
 
 
 
 
 
 
When you change Devices to display in the list to Used points only, only the devices 
used in the program will be displayed. 

 
 
 
 
 
 
 
 
 
 
 
 
 

* is displayed for the
devices in use.
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11.1 Monitor the Devices Used 

11.1.1 Device Monitor 

This screen is to monitor the value stored in any contact points, coils or registers. 
You can also change the data using this screen. 
Monitoring is to be carried out in the following procedure. 
 

1. From menu bar 
Select "Online" -> "Device Monitor". 

 
Or select         on the tool bar. 

 
 
 
 
 
 
 

2. When Device Monitor screen is 
displayed at the right of the program 
edit screen, register the device you 
wish to monitor. 

 
 
 
 
 

 
In Monitor stopped, press         to switch to Monitor executing. 
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■ Monitor the contact point 
Register internal relay R100 to No. 1, and monitor the ON/OFF. 
 
 

1. When you place the cursor on No. 1 and double click it, Register monitor device dialog 
box will be displayed.  
Register R100 and click [OK]. 

 
• Global Devices 
• Device type -> R (internal relay) 
• No. -> 100 
• Number of continuous registrations -> 1 

 
 
 
 

2. R100 is registered and is displayed on Device Monitor screen. 
 
 
 
 
 
 
 

Monitoring of ON/OFF will be carried out in the following procedure. 

 
 

When R100 is ON When R100 is OFF

When R100 is ON,
1 will be displayed.

When R100 is OFF,
0 will be displayed.
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■ Monitor the memory area 
Register DT100 to No. 2 and monitor the data. 
 
 

1. When you place the cursor on No. 2 and double click it, registration dialog box will be 
displayed. 
Register DT100 and click [OK]. 
 
• Device type -> DT (data register) 
• No. -> 100 
• Data type -> Signed 16-bit integer 
• Number of continuous registrations -> 1 

 
 
 
 
 

2. DT100 is registered to Device Monitor screen, and the data are displayed on the current 
value. 
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■ Change the data using Device Monitor 
Change the data of R100 and DT100 registered to Device Monitor. 
 

1. Change the data of R100, and switch ON/OFF. 
Place the cursor on the current value of R100, and double click it. 
 
 
 
 
 
 
 
 
Write contacts dialog box is displayed. 
Select ON and click [OK] to close the 
dialog box. 
 
 
 
R100 is turned ON, and the current value is turned to 1. 
 
 
 
 
 
 
 
 
The contact point of R100 in the ladder program is also turned ON. 
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2. Change the data of DT100. 

Place the cursor on the current value of DT100, and double click it. 
 
 
 
 
 
 
 
 
Write data dialog box is displayed. 
Enter 100 and click [OK] to close the dialog box. 
 
 
 
 
 
 
The Current value of DT100 is turned to 100. 
 
 
 
 
 
 

 
The value of DT100 in the ladder program is also changed similarly. 
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11.2 Monitor PLC Status 

11.2.1 Status Display 

This displays the status of PLC. 
This function is available only in online. 
 
 

1. From menu bar, select "Online" -> "Status 
Display". 

 
Or select         on the tool bar. 

 
 

 
 
 
 
 

2. The Status Display dialog box appears. 
After confirming the status click [Close] to close the dialog box. 
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